Planters Bank

Testing ...


Online & Mobile Banking Minimum Requirements

Your devices and/or browsers must support TLS 1.2. Questions? Call us at 888.806.7036.

AppsMinimum Version Required
Apple iPhone, iPad, iPod TouchiOS 8
Android4.4.4 (KitKat)
BrowsersMinimum Version Required
Apple Safari (Desktop & Mobile)7
Google Chrome38
Microsoft Internet Explorer & IE Mobile11
Microsoft Edge12
Mozilla Firefox27
Opera17